Who should use this Guide:
• Firms who are upgrading from an earlier version of Amicus Attorney

If upgrading from any other version of Amicus (such as Amicus Small Firm), DO NOT USE THIS GUIDE.

Basics

Upgrading your Amicus Attorney installation is a multi-step process. This Guide provides important information about each of the following:
1 System readiness
2 Amicus readiness
3 Performing backups
4 Server upgrade
5 Workstation upgrade

Evaluation and licensing
After upgrading, you will need to re-license Amicus. In the meantime, you may use Amicus in Evaluation mode for 30 days. For information on licensing, see the online Administrator Help available from the Help menu in Amicus.

Servers and workstations
• Amicus Application Server (or Amicus Server)—Primary computer on which you install the Amicus software.
• Amicus Database Server—Computer running Microsoft SQL Server and hosting your Amicus database. Your Amicus Application and Database Servers may be installed on the same computer (an **embedded install**) or
separate computers (a *split install*). For a split install, we recommend that both computers reside in the same subnet and domain.

- **Amicus Workstation**—Computer from which Firm Members will be using Amicus. For best performance and full functionality, ensure that these workstations are on your firm’s network, within the same domain or workgroup as the Amicus Server.

Your Amicus Server may also be used as a workstation but must remain running and connected to the Internet to ensure accessibility by other Firm Members. Even if you do not intend using your Server as a regular workstation, we recommend that you install Workstation components as some configuration steps require you to be logged in to Amicus at the Server.

### SQL Server database

- The Amicus Server installation requires a version of Microsoft SQL Server® (with the latest Service Packs) that’s supported for use with your version of Amicus Attorney. See the *Amicus Attorney Software & Hardware Requirements*, available from the [Technical Guides](#) section of our website.

### Server configuration considerations

- If you choose to upgrade your SQL Server, do that *before or after* the Amicus upgrade. For instructions, see the Appendix to this guide.

- If you choose to move the Amicus Application Server or Database Server to a *different computer* than previously, do that *before or after* the Amicus upgrade. For example, you might wish to change from an embedded install to a split install by moving the Database Server to a separate computer. For instructions, see the *Moving Components of an Amicus Attorney Installation* guide, available from the [Technical Guides](#) section of our website.

- We recommend that firms with *more than 40 Amicus users* consult with Gavel & Gown Technical Support or use the services of an Amicus Independent Consultant before deciding on their server configuration requirements.

---

### Server and Amicus Upgrade Preparation

#### System readiness

Ensure that:

- Your Amicus Application Server computer meets the requirements available from the [Technical Guides](#) section of our website.

- There is sufficient free disk space available on the Amicus Application Server, on the drive where your Temp folder resides. 6 GB is recommended. More might be required, depending on your database size. If a split install, ensure that your Amicus Database Server has at least 2 GB free.

- The latest Windows updates have finished installing. TIP: Check their status from Start > Windows Updates.

- The server is set to never hibernate or sleep. Do this from Control Panel > Power Options. If SQL Server is on a separate computer, ensure that it is also set to never hibernate or sleep.

#### Amicus readiness

1. Ensure that all users are logged out of all Amicus products but remain connected to the network.

2. In User Management, click Deny All to make sure all other users stay logged out.

3. You must be running the most recent Amicus Server Pack for your current version. Contact Technical Support for assistance if necessary.

4. *If the CompuLaw Link was used by the firm*, load any pending Court Rule Updates that you have. Then run your Amicus CompuLaw Date Maintenance process and ensure that your CompuLaw deadlines are updated.
Amicus backups

1. **Back up the Firm Database** (Amicus and AmicusMedia) to a location outside of the Amicus folders. These backups can be performed by choosing Maintenance > Backup in the Firm Settings view of the Office in Amicus and then exit Amicus. Alternatively, you may use SQL Server Enterprise Manager or SQL Management Studio.

2. **If you have a split install** (Amicus Database Server is on a different computer than Amicus Application Server), create the following folder on the Amicus Database Server:
   C:\AmicusDBBackup
   Be sure to select the same drive (C) when selecting one for your automatic backup – see step 7 in the next section.

3. **Back up custom/supplemental files** to a location outside of the Amicus application folder.
   **If upgrading from Amicus Attorney 2013 or lower:**
   - Custom document templates
     By default, located in:
     \Amicus Attorney PE Server\DocumentAssemblyTemplates
   - Custom Reports (and Billing Templates)
     Basic Reports location:
     \Amicus Attorney PE Server\CrystalReportsTemplates
     Advanced Reports (and Amicus Billing Reports and Templates) location:
     \Amicus Attorney PE Server\SQLReportsTemplates
   - Shared documents
     Documents attached to Amicus Files may have been saved or moved to a location under your Amicus application folder. If using the Amicus-Managed Documents feature, the default document location is:
     \Amicus Attorney PE Server\SharedDocuments

   **If upgrading from Amicus Attorney 2014 or higher,** it's only necessary to backup your custom document templates.
   It is not necessary to back up default Amicus templates, or reports that you have not customized.

4. **CompuLaw Rule Sets**—If previously using the CompuLaw Link with Amicus, back up the following items (which contain your CompuLaw Rule Sets):
   \Amicus Attorney PE Server\SmartClient\Server\CompuLaw\COMPULAW.INI and
   \Amicus Attorney PE Server\SmartClient\Server\CompuLaw\DATA
   If installing Amicus Application Server on a new computer, use SQL Management tools to back up the CompuLaw V10 database at the Amicus Server.
   **CAUTION:** If your CompuLaw-database is not stored in \Amicus\Compulaw Database on the Amicus Application Server, or you are not sure, DO NOT PROCEED. Contact Gavel & Gown Technical Support for assistance.

---

Server Upgrade

After ensuring system/Amicus readiness and performing backups, proceed as follows.

1. Log onto Amicus Application Server computer, as a user with Windows “Administrators” Group rights.
2. Shut down all running programs.
3. If you downloaded the Amicus Attorney 2016 DVD image, double-click setup.exe in the extracted contents. Or, if you have a physical DVD, insert it into disk drive of the computer. The setup program should start automatically. If not, click Windows Start button, choose Run, and enter: [disk drive letter]:\Setup.exe
If a message appears saying that specific version(s) of Microsoft .NET Framework must be installed or enabled in order to support basic Amicus functionality, complete the following before proceeding:

- Your Windows operating system might already include the required version(s). Simply enable them as follows:
  - Go to Windows Control Panel > Programs and Features.
  - Choose “Turn Windows features on or off” in the left panel.
  - Select the Microsoft .NET Framework checkbox and click OK.
- Otherwise, download and install applicable version(s) from the Microsoft Download Center.

Then restart the installation of Server components at step 1.

Follow the onscreen instructions.

A System Check will be run to ensure that your server meets system requirements.
If any tests fail, the results are displayed in an Amicus System Check Utility window. (We recommend that you print and save the results from the File menu on the next window.)
If your server fails any essential requirements, you cannot proceed to install—click Exit.

Your existing installation of Amicus Server application will be detected. Select a drive with sufficient disk space for an automatic backup of your existing Firm Database, and click Next.

Click Upgrade. Any available updates will also be applied.

DO NOT INTERRUPT THE UPGRADE PROCESS, AND DO NOT RUN OTHER PROCESSES ON SERVER DURING THIS PERIOD.

Log in to Amicus to verify that the application is running properly.
If you cannot log in successfully, see “Troubleshooting the Server installation” on page 4.

If the CompuLaw Link with Amicus Attorney was used, reinstall the CompuLaw software and prepare your old Court Rules. For instructions, see our website at http://www.amicusattorney.com/support-compulaw-integration.

If your accounting link was configured to automatically handle Amicus Server restarts, Log On settings for the new Amicus PE Service will need to be configured. See “Configuring your system to handle Server restarts” in your Link Guide.

Go to “Workstation Upgrade” on page 5 and follow the instructions.

IMPORTANT:
- Remember to license users before the end of the 30-day evaluation period. For instructions, see Administrator Help in Amicus.
- Do not delete, rename, or move any of the \AMICUS subfolders or files that were created during your Amicus Server installation.
- If your firm intends to license Amicus Billing for the first time with this upgrade, we recommend that you run the Billing Consistency Checker before using billing functionality. This will ensure that your bills and billing reports are accurate. The utility checks for Primary Clients and missing Responsible Lawyers on billable files, for example. Refer to the “Getting Started” topic in the Amicus Billing Administrator Help or User Guide for this and other important setup steps.

Troubleshooting the Server installation

If you need assistance with any of the following procedures, please contact Technical Support.

The Amicus Install Manager log is available on the Server at %temp\AmicusLogs

If you get a connection failure message after you enter your SQL credentials for a split install:
Ensure that the firewall does not block connections to SQL Server. Either disable the firewall or include the following applications in the firewall’s exceptions list:

Under SQL Server 2014:
- C:\Program Files\Microsoft SQL Server\MSSQL12.AMICUS\MSSQL\Binn\sqlservr.exe
- C:\Program Files\Microsoft SQL Server\MSSQL12.AMICUS\Binn\sqlagent.exe

Under SQL Server 2012, the files are under \MSSQL11.AMICUS
If you cannot log in to Amicus:
Ensure that the Amicus services are running, as they might not autostart after computer restarts. At the Amicus Application Server, go to the Windows Control Panel, double-click Administrative Tools, double-click Services, and then start the Amicus services: Amicus DailyCheck Service and Amicus PE Service.

If you cannot log in to Amicus (or a third-party application cannot communicate with Amicus) and are running a firewall:
Ensure that the firewall does not block connections to Amicus components and SQL Server. Either disable the firewall or include the following applications in the firewall’s exceptions list:
- Amicus Application Server and Workstation:
  - C:\Amicus\Amicus Attorney Premium Workstation\AmicusAttorney.XWin.exe
  - C:\Amicus\Amicus Attorney PE Server\SmartClient\Server\AmicusAttorney.XOL.ServerService.exe
- Amicus Database Server:
  Under SQL Server 2014
  - C:\Program Files\Microsoft SQL Server\MSSQL12.AMICUS\MSSQL\Binn\sqlservr.exe
  - C:\Program Files\Microsoft SQL Server\MSSQL12.AMICUS\MSSQL\Binn\sqlagent.exe
  Under SQL Server 2012, the files are under \MSSQL11.AMICUS

If you cannot log in to Amicus after excluding the above issues:
Check the SQL log files for details. See the .TXT files located in: ...
Under SQL Server 2014: C:\Program Files\Microsoft SQL Server\MSSQL12.AMICUS\MSSQL\Data
Under SQL Server 2012, the files are under \MSSQL11.AMICUS
If any errors are logged, please contact Technical Support for assistance.

If the installation was not successful and you need to reinstall:
Complete the following steps to remove any leftover settings or files BEFORE attempting to reinstall Amicus Attorney:

1. From the Windows Control Panel > Programs and Features function, remove Amicus Attorney PE Server and Amicus Installation Manager if present in the list.
2. Open SQL Management Studio from the Windows Start menu: All Programs > Microsoft SQL Server. Expand the Database item at the left, right-click on each of Amicus and AmicusMedia, and choose Delete.
3. In Windows Explorer, browse to the data folder: folder.
   Under SQL Server 2014: C:\Program Files\Microsoft SQL Server\MSSQL12.AMICUS\MSSQL\Data
   Under SQL Server 2012, the files are under \MSSQL11.AMICUS
   Delete the following files if present: Amicus.mdf, Amicus_log.LDF, AmicusMedia_Data.mdf, and AmicusMedia_Log.ldf.

Workstation Upgrade

Before you begin, ensure that
- The Amicus Server upgrade has completed.
- The workstation meets the hardware and software requirements detailed in the System Requirements document, available from the Technical Guides section of our website.
- The workstation and Amicus Server are in the same domain or workgroup, and the workstation has access to the Amicus Server.

If currently at a shared computer or in a terminal server environment: It is only necessary for a single user to upgrade one Amicus Workstation as described below. This will automatically upgrade Amicus for all users on that computer or on all terminal server workstations.

If upgrading an EXISTING Amicus Attorney Workstation

1. Log onto the workstation as a user with Windows “Administrators” or “Power Users” Group rights.
2. Log in to Amicus. A prompt to upgrade the workstation appears. Click OK.
3. Your existing installation of the Workstation will be detected. Click Next and follow the onscreen instructions.
4 If a message appears saying that specific version(s) of Microsoft .NET Framework must be installed or enabled in order to support basic Amicus functionality, complete the following before proceeding:
   • Your Windows operating system might already include the required version(s). Simply enable them as follows:
     a Go to Windows Control Panel > Programs and Features.
     b Choose “Turn Windows features on or off” in the left panel.
     c Select the Microsoft .NET Framework checkbox and click OK.
   • Otherwise, download and install applicable version(s) from the Microsoft Download Center.
   Then restart the upgrade of the Workstation at step 1.

5 When the upgrade process has completed, log in to Amicus at the workstation.

6 A second prompt might appear, saying that a Workstation update is available and asking whether to apply it now. Click OK. If additional prompts appear, click Run. Wait for the update process to complete.

7 If upgrading a Workstation that had the Amicus Tasks Toolbar installed in Adobe Reader or Acrobat, or WordPerfect X5 or later, the Amicus Toolbar might need to be reinstalled in those applications. This is done from your Amicus Preferences: Document Assembly (Step 3). For instructions, see the online Help topic “Setting Up Your Office”.

If installing a NEW Amicus Attorney Workstation

If at a shared computer or in a terminal server environment, you need perform the following steps only once.

1 Log onto the workstation as a user with Windows “Administrators” or “Power Users” Group rights.

2 In Windows Explorer, enter `\\YourAmicusServerName\Install\Workstation` in the Address field, and then double-click `setup.exe` in the folder shown.

3 The Welcome dialog appears. Click Next and follow the onscreen instructions.

4 If a message appears saying that specific version(s) of Microsoft .NET Framework must be installed or enabled in order to support basic Amicus functionality, complete the following before proceeding:
   • Your Windows operating system might already include the required version(s). Simply enable them as follows:
     a Go to Windows Control Panel > Programs and Features.
     b Choose “Turn Windows features on or off” in the left panel.
     c Select the Microsoft .NET Framework checkbox and click OK.
   • Otherwise, download and install applicable version(s) from the Microsoft Download Center.
   Then restart the installation of the Workstation at step 1.

5 When the installation process has completed, log in to Amicus at the workstation. In the Login window that appears, type your User ID and Password provided by your Amicus Administrator. Then click Login.

6 A prompt to automatically add Amicus to your Windows Firewall’s exceptions list might appear. Click OK.

7 A prompt might appear, saying that a Workstation update is available and asking whether to apply it now. Click OK. If additional prompts appear, click Run. Wait for the update process to complete.

8 If you intend leaving Amicus running overnight at the Workstation, ensure that the computer is set to never hibernate or sleep. Do this from Control Panel > Power Options.

If using Amicus Attorney for the first time

After logging in to Amicus, go to the Office module. From there you can set your personal Preferences so that Amicus best meets your needs, in particular:
   • From General > My Profile, click Edit. Adjust your personal information if necessary, and then click Office Access to change your initial Password for security reasons.
• Configure your Document Assembly settings and install Amicus Tasks Toolbars as required. For template merge functionality and other Toolbar integration, ensure that your firewall does not block Microsoft Office applications (Word, Excel, and Outlook) or Corel WordPerfect, as appropriate.

• With the guidance of your Amicus Administrator, install and set up any third-party Links (Exchange/Outlook E-mail, etc.) you might wish to use.

You can safely explore the many features that Amicus offers from the Tutorial Office. Choose Open Tutorial in the Office module. Don't forget to return to your Office when you are ready to start using Amicus.

For detailed instructions and videos on using the many features of Amicus, including setting your personal preferences, see the User Help. It's available from the Help menu in Amicus.
Appendix: Upgrading SQL Server

You have chosen to upgrade your SQL Server version before or after your Amicus upgrade. If you were provided with a 64-bit edition of SQL Server but require a 32-bit edition, please contact Customer Care.

INSTRUCTIONS: Below are basic instructions for upgrading your SQL Server to a new version. Full general instructions are available onscreen during the upgrade.

1. Ensure that the latest SQL Server Service Pack is installed.
2. Ensure that all Amicus Attorney users are logged out. (User access to Amicus Anywhere and TimeTracker, and Client access to the Portal, will also be affected.)
3. In User Management, click Deny All to make sure all other users stay logged out.
5. Log onto your Amicus Database Server, as a user with Windows “Administrators” Group rights. (This might be a different computer than your Amicus Application Server.)
6. Insert the SQL DVD into the disk drive—this may be a “SQL Add On” DVD provided to you for use with Amicus Attorney, or the DVD for your own full-use version of SQL. The Setup program should start automatically. If not, click the Windows Start button, choose Run, and enter [disk drive letter]\setup.exe
7. At the end of this preliminary install, you might be prompted to restart the computer. Then, to resume the installation, re-insert DVD into the disk drive.
8. In the SQL Server Installation Center screen, click Installation at the left, and click the “Upgrade” option at the right.
   The SQL Server Setup wizard starts. Accept the default settings in the subsequent dialogs, EXCEPT in the Instance Configuration dialog, select the AMICUS Instance to upgrade.
10. Log in to Amicus Attorney and ensure that it is functioning properly.
11. In User Maintenance, click Clear Deny to allow all other users to log in.